using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"";
string input = @"АндрейАндреевич�?
��VV�9021021437QТП УФМС
�5� ��� 'Российская Федерация
респуб.@Москва'Российская Федерация
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}