import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:^label:|(?<!\\A)\\G)\\R(\\S+)|^\\w+(?=:))(?=(?:.*\\R)+---)";
final String string = "---\n"
+ "title: This is a title\n"
+ "label:\n"
+ "one\n"
+ "two\n"
+ "three\n"
+ "ultra\n"
+ "description: \"this is a description text\"\n"
+ "other_key: value\n"
+ "---\n\n"
+ "note: this is a note outside the front matter\n"
+ "tip: this is a tip ...\n"
+ "one: this is a one";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}