import Foundation
let pattern = #"(?:(?:^label:|(?<!\A)\G)\R(\S+)|^\w+(?=:))(?=(?:.*\R)+---)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
---
title: This is a title
label:
one
two
three
ultra
description: "this is a description text"
other_key: value
---
note: this is a note outside the front matter
tip: this is a tip ...
one: this is a one
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)