const regex = new RegExp('(?:(?:^label:|(?<!\\A)\\G)\\R(\\S+)|^\\w+(?=:))(?=(?:.*\\R)+---)', 'gm')
const str = `---
title: This is a title
label:
one
two
three
ultra
description: "this is a description text"
other_key: value
---
note: this is a note outside the front matter
tip: this is a tip ...
one: this is a one`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}