package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(-?\d+)\s*\/\s*(\d+) *([+*\/-])\s*(-?\d+)\s*\/(\d+)`)
var str = `-23/45 + 14/9
-23/45 * 14/9
30124/87945 - 987/985`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}