$re = '/(-?\d+)\s*\/\s*(\d+) *([+*\/-])\s*(-?\d+)\s*\/(\d+)/m';
$str = '-23/45 + 14/9
-23/45 * 14/9
30124/87945 - 987/985';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);