const regex = new RegExp('(-?\\d+)\\s*\\/\\s*(\\d+) *([+*\\/-])\\s*(-?\\d+)\\s*\\/(\\d+)', 'gm')
const str = `-23/45 + 14/9
-23/45 * 14/9
30124/87945 - 987/985`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}