using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z0-9-]+):([a-zA-Z0-9-]+)";
string substitution = @"""$1"":""$2""";
string input = @"{
time: {
from:now-60d,
mode:quick,
to:now }
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}