#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^([A-Z][a-z-]+),? +([A-Z])[^\n]*"
Local $sString = "Grundy Ronald" & @CRLF & _
"Domsky Alan" & @CRLF & _
"Amator Gary L & Kathleen N" & @CRLF & _
"Worden Scott Allen" & @CRLF & _
"Rodriguez Howard W" & @CRLF & _
"NEHME ALLEN " & @CRLF & _
"RODRIGUEZ CHARLES G" & @CRLF & _
"VERGARA WILLIAM F J" & @CRLF & _
"EVELYN J" & @CRLF & _
"GLICK, JACOB L. " & @CRLF & _
"Taylor-garcia Dottielou"
Local $sSubst = "$2-$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)