const regex = /^([A-Z][a-z-]+),? +([A-Z])[^\n]*/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z][a-z-]+),? +([A-Z])[^\\n]*', 'gim')
const str = `Grundy Ronald
Domsky Alan
Amator Gary L & Kathleen N
Worden Scott Allen
Rodriguez Howard W
NEHME ALLEN
RODRIGUEZ CHARLES G
VERGARA WILLIAM F J
EVELYN J
GLICK, JACOB L.
Taylor-garcia Dottielou`;
const subst = `$2-$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);