import re
regex = re.compile(r"^([A-Z][a-z-]+),? +([A-Z])[^\n]*", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("Grundy Ronald\n"
"Domsky Alan\n"
"Amator Gary L & Kathleen N\n"
"Worden Scott Allen\n"
"Rodriguez Howard W\n"
"NEHME ALLEN \n"
"RODRIGUEZ CHARLES G\n"
"VERGARA WILLIAM F J\n"
"EVELYN J\n"
"GLICK, JACOB L. \n"
"Taylor-garcia Dottielou")
subst = "$2-$1"
result = regex.sub(subst, test_str)
if result:
print(result)