import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!<div class=\\\"ignore\\\">)(\\n<h([1-6]{1})[^>]*)>.*<\\/h\\2>";
final String string = "<div class=\"wrapper\">\n"
+ "<h2>This is a header</h2>\n"
+ "<h2>This is one too/h2>\n"
+ "<h4>Here's one</h4>\n"
+ "<div class=\"ignore\">\n"
+ "<h5>I'm one in here too</h5>\n"
+ "</div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}