const regex = /(?<!<div class=\"ignore\">)(\n<h([1-6]{1})[^>]*)>.*<\/h\2>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!<div class=\\"ignore\\">)(\\n<h([1-6]{1})[^>]*)>.*<\\\/h\\2>', 'g')
const str = `<div class="wrapper">
<h2>This is a header</h2>
<h2>This is one too/h2>
<h4>Here's one</h4>
<div class="ignore">
<h5>I'm one in here too</h5>
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}