$re = '/(?<!<div class=\"ignore\">)(\n<h([1-6]{1})[^>]*)>.*<\/h\2>/';
$str = '<div class="wrapper">
<h2>This is a header</h2>
<h2>This is one too/h2>
<h4>Here\'s one</h4>
<div class="ignore">
<h5>I\'m one in here too</h5>
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);