#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(-scaled|[_-]\d+x\d+)|@[2-6]\x(?=\.[a-z]{3,4}$)|\.[a-z]{3,4}.webp"
Local $sString = "skip-IMG_7484-scaled.jpg" & @CRLF & _
"skip-IMG_7484.jpeg.webp" & @CRLF & _
"skip-IMG_7484.jpg.webp" & @CRLF & _
"skip-filename_500x383dddd.jpeg" & @CRLF & _
"skip-filename_500x383.jpeg" & @CRLF & _
"skip-filename-500x383.jpeg" & @CRLF & _
"skip-filename-500x383.jpg" & @CRLF & _
"skip-filename-500x383@2xddddd.jpg" & @CRLF & _
"skip-filename-500x383@2x.jpg" & @CRLF & _
"skip-filename-100x100@2x.jpg" & @CRLF & _
"skip-filename-1000x1000@3x.jpg" & @CRLF & _
"skip-filename-40x40@4x.jpg" & @CRLF & _
"keep-filename@2x copy.jpg" & @CRLF & _
"keep-filename@2x.jpg" & @CRLF & _
"keep-filename@3x.jpg" & @CRLF & _
"keep-filename@4x.jpg" & @CRLF & _
"keep-IMG_7484-normal-webp.webp" & @CRLF & _
"keep-IMG_7484-not-dot-jpg.webp" & @CRLF & _
"keep-IMG_7484.jpg" & @CRLF & _
"keep-f5229.jpg" & @CRLF & _
"keep-f5229as'ad"an.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")