using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-scaled|[_-]\d+x\d+)|@[2-6]\x(?=\.[a-z]{3,4}$)|\.[a-z]{3,4}.webp";
string input = @"skip-IMG_7484-scaled.jpg
skip-IMG_7484.jpeg.webp
skip-IMG_7484.jpg.webp
skip-filename_500x383dddd.jpeg
skip-filename_500x383.jpeg
skip-filename-500x383.jpeg
skip-filename-500x383.jpg
skip-filename-500x383@2xddddd.jpg
skip-filename-500x383@2x.jpg
skip-filename-100x100@2x.jpg
skip-filename-1000x1000@3x.jpg
skip-filename-40x40@4x.jpg
keep-filename@2x copy.jpg
keep-filename@2x.jpg
keep-filename@3x.jpg
keep-filename@4x.jpg
keep-IMG_7484-normal-webp.webp
keep-IMG_7484-not-dot-jpg.webp
keep-IMG_7484.jpg
keep-f5229.jpg
keep-f5229as'ad""an.jpg";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}