#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9][0-9]?(?:[,|][1-9][0-9]?)*$"
Local $sString = "Must accept:" & @CRLF & _
"1" & @CRLF & _
"10" & @CRLF & _
"1,2,3|5|10,20|30" & @CRLF & _
"1|5" & @CRLF & _
"" & @CRLF & _
"Must refuse:" & @CRLF & _
"1," & @CRLF & _
"10,," & @CRLF & _
"1,2,3!5" & @CRLF & _
"1|100" & @CRLF & _
"0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")