package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9][0-9]?(?:[,|][1-9][0-9]?)*$`)
var str = `Must accept:
1
10
1,2,3|5|10,20|30
1|5
Must refuse:
1,
10,,
1,2,3!5
1|100
0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}