$re = '/^[1-9][0-9]?(?:[,|][1-9][0-9]?)*$/m';
$str = 'Must accept:
1
10
1,2,3|5|10,20|30
1|5
Must refuse:
1,
10,,
1,2,3!5
1|100
0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);