import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:com\\.docker\\.|io\\.docker\\.|org\\.dockerproject\\.))(?=.*[a-z]$)[a-z](?:[a-z0-9]|(?<!\\.)\\.(?!\\.)|(?<!-)-(?!-))*$";
final String string = "com.docker.evil\n"
+ "01234\n"
+ "-a\n"
+ "a-\n"
+ ".a\n"
+ "a.\n"
+ "0abc\n"
+ "abc0\n"
+ "foo..bar\n"
+ "baz--fiz\n"
+ "goofy🙄ahh\n"
+ "a\n"
+ "correct.label\n"
+ "correct-label\n"
+ "label4a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}