import re
regex = re.compile(r"^(?!(?:com\.docker\.|io\.docker\.|org\.dockerproject\.))(?=.*[a-z]$)[a-z](?:[a-z0-9]|(?<!\.)\.(?!\.)|(?<!-)-(?!-))*$", flags=re.MULTILINE)
test_str = ("com.docker.evil\n"
"01234\n"
"-a\n"
"a-\n"
".a\n"
"a.\n"
"0abc\n"
"abc0\n"
"foo..bar\n"
"baz--fiz\n"
"goofy🙄ahh\n"
"a\n"
"correct.label\n"
"correct-label\n"
"label4a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")