const regex = /^(?!(?:com\.docker\.|io\.docker\.|org\.dockerproject\.))(?=.*[a-z]$)[a-z](?:[a-z0-9]|(?<!\.)\.(?!\.)|(?<!-)-(?!-))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:com\\.docker\\.|io\\.docker\\.|org\\.dockerproject\\.))(?=.*[a-z]$)[a-z](?:[a-z0-9]|(?<!\\.)\\.(?!\\.)|(?<!-)-(?!-))*$', 'gm')
const str = `com.docker.evil
01234
-a
a-
.a
a.
0abc
abc0
foo..bar
baz--fiz
goofy🙄ahh
a
correct.label
correct-label
label4a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}