package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|;) ?somename=([^;]*)(;|$)`)
var str = `cookie1=value1;somename=value2;cookie3=value3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}