re = /(^|;) ?somename=([^;]*)(;|$)/
str = 'cookie1=value1;somename=value2;cookie3=value3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end