$re = '/(^|;) ?somename=([^;]*)(;|$)/';
$str = 'cookie1=value1;somename=value2;cookie3=value3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);