const regex = /\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+', 'gm')
const str = `One Two Three`;
const subst = `<span id="$&"></span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);