use strict;
my $str = 'One Two Three';
my $regex = qr/\S+/mp;
my $subst = '<span id="$&"></span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";