$re = '/\S+/m';
$str = 'One Two Three';
$subst = "<span id=\"$&\"></span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;