#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):61:(\d{6})(\d+)(\D{1,2})(\D?)([\d,]{2,15})(\D{1})(\w{3})(.+?)(?=//)//(.{0,16})"
Local $sString = ":61:090124D10000000,S202DRS/06553" & @CRLF & _
"" & @CRLF & _
":61:1507020702D115945,00F014NARRATIVE//0207150143062089" & @CRLF & _
"" & @CRLF & _
":61:170929D546232,05S101PLTOL101-56//C11126A1378" & @CRLF & _
"" & @CRLF & _
":61:170929D100000,NFEXAAAAUS0369PLATUS//8954321" & @CRLF & _
"" & @CRLF & _
":61:090124D10000000,S202DRS/06553"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")