using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":61:(\d{6})(\d+)(\D{1,2})(\D?)([\d,]{2,15})(\D{1})(\w{3})(.+?)(?=//)//(.{0,16})";
string input = @":61:090124D10000000,S202DRS/06553
:61:1507020702D115945,00F014NARRATIVE//0207150143062089
:61:170929D546232,05S101PLTOL101-56//C11126A1378
:61:170929D100000,NFEXAAAAUS0369PLATUS//8954321
:61:090124D10000000,S202DRS/06553";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}