import Foundation
let pattern = #":61:(\d{6})(\d+)(\D{1,2})(\D?)([\d,]{2,15})(\D{1})(\w{3})(.+?)(?=//)//(.{0,16})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
:61:090124D10000000,S202DRS/06553
:61:1507020702D115945,00F014NARRATIVE//0207150143062089
:61:170929D546232,05S101PLTOL101-56//C11126A1378
:61:170929D100000,NFEXAAAAUS0369PLATUS//8954321
:61:090124D10000000,S202DRS/06553
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)