using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[tT][\s _-]*[lL]\s*[aA]\s*[uU]\s*[nN]\s*[cC]\s*[hH]\s*[eE]\s*[rR]";
string input = @"t launcher
t launcher
just use t launcher
just use t LauNCher
just use t-launcher
jsut use t-LaunCherr
jsut use t_LaunCherr
t la u ncher
T lauNCh Er
minecfrat T launcHER
miencaraft launcher
minecraft launcher";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}