// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[tT][\s _-]*[lL]\s*[aA]\s*[uU]\s*[nN]\s*[cC]\s*[hH]\s*[eE]\s*[rR]").unwrap();
let string = "t launcher
t launcher
just use t launcher
just use t LauNCher
just use t-launcher
jsut use t-LaunCherr
jsut use t_LaunCherr
t la u ncher
T lauNCh Er
minecfrat T launcHER
miencaraft launcher
minecraft launcher";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}