$re = '/\b[tT][\s _-]*[lL]\s*[aA]\s*[uU]\s*[nN]\s*[cC]\s*[hH]\s*[eE]\s*[rR]/m';
$str = 't launcher
t launcher
just use t launcher
just use t LauNCher
just use t-launcher
jsut use t-LaunCherr
jsut use t_LaunCherr
t la u ncher
T lauNCh Er
minecfrat T launcHER
miencaraft launcher
minecraft launcher';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);