#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(.+)$(?=[\s\S]*^(\1)$[\s\S]*)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"An HTML attachment was scrubbed..." & @CRLF & _
"URL: https://list.something.edu/mailman/attachments/200908002/7452/attachment.html" & @CRLF & _
"From SomeAddress at SomeDomain.org SomeDate" & @CRLF & _
"From: SomeonesEmail at SomeDomain.org (FirstName LastName)" & @CRLF & _
"Date: [the date]" & @CRLF & _
"Subject: [ListservName] SomeSubject" & @CRLF & _
"In-Reply-To: <SomeIDnumber>" & @CRLF & _
"References: <%SomeEmailAddress>" & @CRLF & _
" <SomeIDnumber>" & @CRLF & _
"Message-ID: <SomeIDnumber>" & @CRLF & _
"" & @CRLF & _
"Hey there, Everyone," & @CRLF & _
"" & @CRLF & _
"I completely disagree with this. It's crap!" & @CRLF & _
"" & @CRLF & _
"Sincerely," & @CRLF & _
"SomePerson" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"On SomeDate, Someone wrote:" & @CRLF & _
"From: SomeonesEmail at SomeDomain.org (FirstName LastName)" & @CRLF & _
"Date: [the date]" & @CRLF & _
"Subject: [ListservName] SomeSubject" & @CRLF & _
"In-Reply-To: <SomeIDnumber>" & @CRLF & _
"References: <%SomeEmailAddress>" & @CRLF & _
" <SomeIDnumber>" & @CRLF & _
"Message-ID: <SomeIDnumber>" & @CRLF & _
"" & @CRLF & _
"Hey PersonA," & @CRLF & _
"" & @CRLF & _
"This is my advice. It is really good advice. I hope you take it since I think it's pertinent." & @CRLF & _
"" & @CRLF & _
"Sincerely," & @CRLF & _
"PersonZ" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"An HTML attachment was scrubbed..." & @CRLF & _
"URL: https://list.something.edu/mailman/attachments/200908002/7452/attachment.html" & @CRLF & _
"From SomeAdress at SomeDomain.org SomeDate" & @CRLF & _
"From: SomeonesEmail at SomeDomain.org (FirstName LastName)" & @CRLF & _
"Date: [the date]" & @CRLF & _
"Subject: [ListservName] SomeSubject" & @CRLF & _
"In-Reply-To: <SomeIDnumber>" & @CRLF & _
"References: <%SomeEmailAddress>" & @CRLF & _
" <SomeIDnumber>" & @CRLF & _
"Message-ID: <SomeIDnumber>" & @CRLF & _
"" & @CRLF & _
"Good Afternoon, PersonA," & @CRLF & _
"" & @CRLF & _
"But have you considered this aspect? It changes everything, so this is my advice. It is even better advice! " & @CRLF & _
"" & @CRLF & _
"Sincerely," & @CRLF & _
"PersonB" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"On SomeDate, PersonZ wrote:" & @CRLF & _
"" & @CRLF & _
"Hey PersonA," & @CRLF & _
"" & @CRLF & _
"This is my advice. It" & @CRLF & _
"is really" & @CRLF & _
"good advice. I hope you take it since I" & @CRLF & _
"think it's pertinent." & @CRLF & _
"" & @CRLF & _
"Sincerely," & @CRLF & _
"PersonZ" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"From SomeAddress at SomeDomain.org SomeDate " & @CRLF & _
"From: SomeonesEmail at SomeDomain.org (FirstName LastName)" & @CRLF & _
"Date: [the date]" & @CRLF & _
"Subject: [ListservName] SomeSubject" & @CRLF & _
"In-Reply-To: <SomeIDnumber>" & @CRLF & _
"References: <%SomeEmailAddress>" & @CRLF & _
" <SomeIDnumber>" & @CRLF & _
"Message-ID: <SomeIDnumber>" & @CRLF & _
"" & @CRLF & _
"Thank you all for your feedback on this issue. You've given me a lot to" & @CRLF & _
"consider. Cheers." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[And so on.]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")