const regex = /^(.+)$(?=[\s\S]*^(\1)$[\s\S]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)$(?=[\\s\\S]*^(\\1)$[\\s\\S]*)', 'g')
const str = `
An HTML attachment was scrubbed...
URL: https://list.something.edu/mailman/attachments/200908002/7452/attachment.html
From SomeAddress at SomeDomain.org SomeDate
From: SomeonesEmail at SomeDomain.org (FirstName LastName)
Date: [the date]
Subject: [ListservName] SomeSubject
In-Reply-To: <SomeIDnumber>
References: <%SomeEmailAddress>
<SomeIDnumber>
Message-ID: <SomeIDnumber>
Hey there, Everyone,
I completely disagree with this. It's crap!
Sincerely,
SomePerson
On SomeDate, Someone wrote:
From: SomeonesEmail at SomeDomain.org (FirstName LastName)
Date: [the date]
Subject: [ListservName] SomeSubject
In-Reply-To: <SomeIDnumber>
References: <%SomeEmailAddress>
<SomeIDnumber>
Message-ID: <SomeIDnumber>
Hey PersonA,
This is my advice. It is really good advice. I hope you take it since I think it's pertinent.
Sincerely,
PersonZ
An HTML attachment was scrubbed...
URL: https://list.something.edu/mailman/attachments/200908002/7452/attachment.html
From SomeAdress at SomeDomain.org SomeDate
From: SomeonesEmail at SomeDomain.org (FirstName LastName)
Date: [the date]
Subject: [ListservName] SomeSubject
In-Reply-To: <SomeIDnumber>
References: <%SomeEmailAddress>
<SomeIDnumber>
Message-ID: <SomeIDnumber>
Good Afternoon, PersonA,
But have you considered this aspect? It changes everything, so this is my advice. It is even better advice!
Sincerely,
PersonB
On SomeDate, PersonZ wrote:
Hey PersonA,
This is my advice. It
is really
good advice. I hope you take it since I
think it's pertinent.
Sincerely,
PersonZ
From SomeAddress at SomeDomain.org SomeDate
From: SomeonesEmail at SomeDomain.org (FirstName LastName)
Date: [the date]
Subject: [ListservName] SomeSubject
In-Reply-To: <SomeIDnumber>
References: <%SomeEmailAddress>
<SomeIDnumber>
Message-ID: <SomeIDnumber>
Thank you all for your feedback on this issue. You've given me a lot to
consider. Cheers.
[And so on.]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}