using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)$(?=[\s\S]*^(\1)$[\s\S]*)";
string input = @"
An HTML attachment was scrubbed...
URL: https://list.something.edu/mailman/attachments/200908002/7452/attachment.html
From SomeAddress at SomeDomain.org SomeDate
From: SomeonesEmail at SomeDomain.org (FirstName LastName)
Date: [the date]
Subject: [ListservName] SomeSubject
In-Reply-To: <SomeIDnumber>
References: <%SomeEmailAddress>
<SomeIDnumber>
Message-ID: <SomeIDnumber>
Hey there, Everyone,
I completely disagree with this. It's crap!
Sincerely,
SomePerson
On SomeDate, Someone wrote:
From: SomeonesEmail at SomeDomain.org (FirstName LastName)
Date: [the date]
Subject: [ListservName] SomeSubject
In-Reply-To: <SomeIDnumber>
References: <%SomeEmailAddress>
<SomeIDnumber>
Message-ID: <SomeIDnumber>
Hey PersonA,
This is my advice. It is really good advice. I hope you take it since I think it's pertinent.
Sincerely,
PersonZ
An HTML attachment was scrubbed...
URL: https://list.something.edu/mailman/attachments/200908002/7452/attachment.html
From SomeAdress at SomeDomain.org SomeDate
From: SomeonesEmail at SomeDomain.org (FirstName LastName)
Date: [the date]
Subject: [ListservName] SomeSubject
In-Reply-To: <SomeIDnumber>
References: <%SomeEmailAddress>
<SomeIDnumber>
Message-ID: <SomeIDnumber>
Good Afternoon, PersonA,
But have you considered this aspect? It changes everything, so this is my advice. It is even better advice!
Sincerely,
PersonB
On SomeDate, PersonZ wrote:
Hey PersonA,
This is my advice. It
is really
good advice. I hope you take it since I
think it's pertinent.
Sincerely,
PersonZ
From SomeAddress at SomeDomain.org SomeDate
From: SomeonesEmail at SomeDomain.org (FirstName LastName)
Date: [the date]
Subject: [ListservName] SomeSubject
In-Reply-To: <SomeIDnumber>
References: <%SomeEmailAddress>
<SomeIDnumber>
Message-ID: <SomeIDnumber>
Thank you all for your feedback on this issue. You've given me a lot to
consider. Cheers.
[And so on.]
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}