package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,2}\/\d{1,2}\/\d{4}$`)
var str = `12/12/2019
12/1/219
0/12/2019
12/212/2019`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}