re = /^\d{1,2}\/\d{1,2}\/\d{4}$/m
str = '12/12/2019
12/1/219
0/12/2019
12/212/2019'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end