$re = '/^\d{1,2}\/\d{1,2}\/\d{4}$/m';
$str = '12/12/2019
12/1/219
0/12/2019
12/212/2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);