#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+(?:\.\d+)*)\s+(.+?)\s+(\d{1,3}(?:\.\d{3})*,\d{2})\s+(\d{1,3}(?:\.\d{3})*,\d{2})(?:\s+(\d{1,3}(?:\.\d{3})*,\d{2}(?:\s+[CD])?))?$"
Local $sString = "Random number Account number Account Name credit$ Debt$ Value of account" & @CRLF & _
"10 53 Another Financial Instruments 1.100,00 1.500,00 400,00 D" & @CRLF & _
"531 Café C/C (Taxes) 100,00 50,00 50,00 C" & @CRLF & _
"230 5321 Example 100,00 50,00 50,00 C" & @CRLF & _
"54 Example 2 300,00 500,00 200,00 D" & @CRLF & _
"" & @CRLF & _
"Account number Account Name credit$ Debt$ Value of account" & @CRLF & _
"5.3 Another Financial Instruments 1.100,00 1.500,00 400,00" & @CRLF & _
"5.3.1 Café C/C (Taxes) 100,00 50,00 50,00" & @CRLF & _
"5.3.2.1 Example 100,00 50,00 50,00" & @CRLF & _
"5.4 Example 2 300,00 500,00 200,00" & @CRLF & _
"" & @CRLF & _
"Account number Account Name credit$ Debt$" & @CRLF & _
"53 Another Financial Instruments 1.100,00 1.500,00" & @CRLF & _
"531 Café C/C (Taxes) 100,00 50,00" & @CRLF & _
"5321 Example 100,00 50,00" & @CRLF & _
"54 Example 2 300,00 500,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")