import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+(?:\\.\\d+)*)\\s+(.+?)\\s+(\\d{1,3}(?:\\.\\d{3})*,\\d{2})\\s+(\\d{1,3}(?:\\.\\d{3})*,\\d{2})(?:\\s+(\\d{1,3}(?:\\.\\d{3})*,\\d{2}(?:\\s+[CD])?))?$";
final String string = "Random number Account number Account Name credit$ Debt$ Value of account\n"
+ "10 53 Another Financial Instruments 1.100,00 1.500,00 400,00 D\n"
+ "531 Café C/C (Taxes) 100,00 50,00 50,00 C\n"
+ "230 5321 Example 100,00 50,00 50,00 C\n"
+ "54 Example 2 300,00 500,00 200,00 D\n\n"
+ "Account number Account Name credit$ Debt$ Value of account\n"
+ "5.3 Another Financial Instruments 1.100,00 1.500,00 400,00\n"
+ "5.3.1 Café C/C (Taxes) 100,00 50,00 50,00\n"
+ "5.3.2.1 Example 100,00 50,00 50,00\n"
+ "5.4 Example 2 300,00 500,00 200,00\n\n"
+ "Account number Account Name credit$ Debt$\n"
+ "53 Another Financial Instruments 1.100,00 1.500,00\n"
+ "531 Café C/C (Taxes) 100,00 50,00\n"
+ "5321 Example 100,00 50,00\n"
+ "54 Example 2 300,00 500,00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}