import re
regex = re.compile(r"^(\d+(?:\.\d+)*)\s+(.+?)\s+(\d{1,3}(?:\.\d{3})*,\d{2})\s+(\d{1,3}(?:\.\d{3})*,\d{2})(?:\s+(\d{1,3}(?:\.\d{3})*,\d{2}(?:\s+[CD])?))?$", flags=re.MULTILINE)
test_str = ("Random number Account number Account Name credit$ Debt$ Value of account\n"
"10 53 Another Financial Instruments 1.100,00 1.500,00 400,00 D\n"
"531 Café C/C (Taxes) 100,00 50,00 50,00 C\n"
"230 5321 Example 100,00 50,00 50,00 C\n"
"54 Example 2 300,00 500,00 200,00 D\n\n"
"Account number Account Name credit$ Debt$ Value of account\n"
"5.3 Another Financial Instruments 1.100,00 1.500,00 400,00\n"
"5.3.1 Café C/C (Taxes) 100,00 50,00 50,00\n"
"5.3.2.1 Example 100,00 50,00 50,00\n"
"5.4 Example 2 300,00 500,00 200,00\n\n"
"Account number Account Name credit$ Debt$\n"
"53 Another Financial Instruments 1.100,00 1.500,00\n"
"531 Café C/C (Taxes) 100,00 50,00\n"
"5321 Example 100,00 50,00\n"
"54 Example 2 300,00 500,00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")