const regex = /^\d*(?:([., ])(?:\d{3}\1)*\d{3})?(?:[.,]\d*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d*(?:([., ])(?:\\d{3}\\1)*\\d{3})?(?:[.,]\\d*)?$', 'gm')
const str = `1,000
1000.00
1,000,000.00
2.000.000,00
123748
4 294 967 295,000
0.24
.24
24
24.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}