import re
regex = re.compile(r"^\d*(?:([., ])(?:\d{3}\1)*\d{3})?(?:[.,]\d*)?$", flags=re.MULTILINE)
test_str = ("1,000\n"
"1000.00\n"
"1,000,000.00\n"
"2.000.000,00\n"
"123748\n"
"4 294 967 295,000\n"
"0.24\n"
".24\n"
"24\n"
"24.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")