$re = '/^\d*(?:([., ])(?:\d{3}\1)*\d{3})?(?:[.,]\d*)?$/m';
$str = '1,000
1000.00
1,000,000.00
2.000.000,00
123748
4 294 967 295,000
0.24
.24
24
24.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);