const regex = /(?<=,|\t)(.*?)(?=,|\n)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=,|\\t)(.*?)(?=,|\\n)', 'mg')
const str = ` marjorie.bienert@soprasteria.com,adel.amari@ext.soprasteria.com,marcos.martinez@soprasteria.com,angeline.marie@soprasteria.com,frederic.lecomte2@soprasteria.com,stephane.gaston@sante.gouv.fr,juan-cristobal.peinado@soprasteria.com,philippe.bourdin@sante.gouv.fr,alejandro-horacio.ramos@soprasteria.com,thomas.bernstein@soprasteria.com,iman.ouazzani@soprasteria.com,anthony.jacq@soprasteria.com,jorge.moraistejerina@soprasteria.com,camille.rolland@soprasteria.com,sebastien.dufay@soprasteria.com,soufiane.mouflih@ext.soprasteria.com,adama.sakho@soprasteria.com,deuneuv.makoundou@soprasteria.com,manel.bejaoui@soprasteria.com,etienne.lorteau@soprasteria.com,javier.pina@soprasteria.com,paloma.fernandez@soprasteria.com,victoire.legrand@soprasteria.com,timothee.luyt@soprasteria.com,francisco-javier.soriano@soprasteria.com,christophe.lauv@soprasteria.com,thibault.louis@soprasteria.com,yolanda.torres@soprasteria.com
admin.platines@asipsante.fr E A noreply.platines@asipsante.fr
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}