$re = '/(?<=,|\t)(.*?)(?=,|\n)/m';
$str = ' marjorie.bienert@soprasteria.com,adel.amari@ext.soprasteria.com,marcos.martinez@soprasteria.com,angeline.marie@soprasteria.com,frederic.lecomte2@soprasteria.com,stephane.gaston@sante.gouv.fr,juan-cristobal.peinado@soprasteria.com,philippe.bourdin@sante.gouv.fr,alejandro-horacio.ramos@soprasteria.com,thomas.bernstein@soprasteria.com,iman.ouazzani@soprasteria.com,anthony.jacq@soprasteria.com,jorge.moraistejerina@soprasteria.com,camille.rolland@soprasteria.com,sebastien.dufay@soprasteria.com,soufiane.mouflih@ext.soprasteria.com,adama.sakho@soprasteria.com,deuneuv.makoundou@soprasteria.com,manel.bejaoui@soprasteria.com,etienne.lorteau@soprasteria.com,javier.pina@soprasteria.com,paloma.fernandez@soprasteria.com,victoire.legrand@soprasteria.com,timothee.luyt@soprasteria.com,francisco-javier.soriano@soprasteria.com,christophe.lauv@soprasteria.com,thibault.louis@soprasteria.com,yolanda.torres@soprasteria.com
admin.platines@asipsante.fr E A noreply.platines@asipsante.fr
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);