import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?:^```\\h*\\S+\\s+\\K|\\G(?!\\A))^(?!```)(.*\\R+)(?:```)?";
final String string = "Do not change this line\n\n"
+ "```markdown\n"
+ "Sasha great!\n"
+ " Sasha nice!\n"
+ "She is beautiful, surprise!\n"
+ "```\n"
+ "Do not change this line\n\n"
+ "Do not change this line\n\n"
+ "```markdown\n"
+ "Sasha great!\n"
+ " Sasha nice!\n"
+ "She is beautiful, surprise!\n"
+ "```\n\n"
+ "Do not change this line\n\n\n"
+ "Do not change this line\n\n"
+ "```markdown\n"
+ "Sasha great!\n"
+ " Sasha nice!\n"
+ "She is beautiful, surprise!\n"
+ "```\n\n"
+ "Do not change this line\n\n\n"
+ "Do not change this line\n\n"
+ "```markdown\n"
+ "Sasha great!\n"
+ " Sasha nice!\n"
+ "She is beautiful, surprise!\n"
+ "```\n\n"
+ "Do not change this line";
final String subst = "\\t\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}