# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?:^```\h*\S+\s+\K|\G(?!\A))^(?!```)(.*\R+)(?:```)?"
test_str = ("Do not change this line\n\n"
"```markdown\n"
"Sasha great!\n"
" Sasha nice!\n"
"She is beautiful, surprise!\n"
"```\n"
"Do not change this line\n\n"
"Do not change this line\n\n"
"```markdown\n"
"Sasha great!\n"
" Sasha nice!\n"
"She is beautiful, surprise!\n"
"```\n\n"
"Do not change this line\n\n\n"
"Do not change this line\n\n"
"```markdown\n"
"Sasha great!\n"
" Sasha nice!\n"
"She is beautiful, surprise!\n"
"```\n\n"
"Do not change this line\n\n\n"
"Do not change this line\n\n"
"```markdown\n"
"Sasha great!\n"
" Sasha nice!\n"
"She is beautiful, surprise!\n"
"```\n\n"
"Do not change this line")
subst = "\\t\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.